Opened 13 years ago

Closed 13 years ago

#11 closed defect (duplicate)

Add music intervals

Reported by: bfinn Owned by:
Priority: minor Milestone:
Component: Keywords:
Cc:

Description

I suggest you add units for musical intervals, used in music itself, scientific instruments such as electronic tuning meters, acoustics, psychoacoustics, etc. As your system includes bels and mentions the possibility of defining phons and sones, musical intervals would seem a natural addition.

Musical intervals are unitless logarithmic ratios of pitch frequencies. A useful set would be the following four:

octave = base 2 logarithm of frequency ratio; e.g. f1/f2 = 2 means the interval between f1 and f2 is 1 octave

cent = 1/1200 octave. So e.g. 600 cents denotes a frequency ratio of 20.5 = 1.414...

semitone (equal-tempered) or half step (equal-tempered) = 100 cents

tone (equal-tempered) or whole step (equal-tempered) = 200 cents

Semitone/tone are British terms, half/whole step are equivalent US terms. Note that like calendar months, these particular units can vary in size depending on the tuning system ('temperament') in use. However, nowadays 'equal temperament' is almost always used, in which semitones are of a fixed size of 100 cents. (They are hence rather like mean calendar months.) Cents and octaves are always of fixed size regardless of the tuning system.

The cent is a rather technical unit used in tuning rather than in everyday music. Semitone and, to a lesser extent, tone and octave are used in scientific as well as musical contexts. There are various other intervals used in musical rather than scientific contexts which are multiples of a semitone (e.g. minor third, fourth, tritone), but probably not worth including.

Ben Finn (ben@…)

Change History (1)

comment:1 Changed 13 years ago by Gunther Schadow

Resolution: duplicate
Status: newclosed

This is duplicate of #10.

Very interesting suggestion. Thanks.

Note: See TracTickets for help on using tickets.